Skip to main content
← All vulnerabilities
CVE-2025-62265GHSA-56JV-4WW3-65MW

Cross-site scripting (XSS) vulnerability in the Blogs widget in Liferay Portal 7.4.0 through 7.4.3.111, and older unsupported versions, and

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.4.3.112-ga112
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Cross-site scripting (XSS) vulnerability in the Blogs widget in Liferay Portal 7.4.0 through 7.4.3.111, and older unsupported versions, and Liferay DXP 2023.Q4.0 through 2023.Q4.10, 2023.Q3.1 through 2023.Q3.8, 7.4 GA through update 92, 7.3 GA through update 36, and older unsupported versions allows remote attackers to inject arbitrary web script or HTML via a crafted <iframe> injected into a blog entry's “Content” text field The Blogs widget in Liferay DXP does not add the sandbox attribute to <iframe> elements, which allows remote attackers to access the parent page via scripts and links in the frame page.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Liferay Portal

    From 7.4.0 · through 7.4.3.111

  • Liferay DXP

    From 7.4.13 · through 7.4.13-u92; From 2023.Q3.1 · through 2023.Q3.8; From 2023.Q4.0 · through 2023.Q4.10

  • com.liferay.portal:release.portal.bomMaven

    From 7.4.0-ga1 · fixed in 7.4.3.112-ga112

References 1

liferay.dev