Skip to main content
← All vulnerabilities
CVE-2025-62164PYSEC-2026-2018GHSA-MRW7-HF4F-83PF

VLLM deserialization vulnerability leading to DoS and potential RCE

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.11.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • vllm-project vllm

    From 0.10.2 · fixed in 0.11.1

  • vllmPyPI

    From 0.10.2 · fixed in 0.11.1

References 3

GitHub · vllm-project/vllm