Skip to main content
← All vulnerabilities
CVE-2025-61734GHSA-P86W-W5RH-M3HX

Apache Kylin: improper restriction of file read

Published
Last modified
published
Not listed in CISA KEV
Low (apache)
Fix
Fixed in 5.0.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Files or Directories Accessible to External Parties vulnerability in Apache Kylin. You are fine as long as the Kylin's system and project admin access is well protected. This issue affects Apache Kylin: from 4.0.0 through 5.0.2. Users are recommended to upgrade to version 5.0.3, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Apache Software Foundation Apache Kylin

    From 4.0.0 · through 5.0.2

  • org.apache.kylin:kylinMaven

    From 4.0.0 · fixed in 5.0.3

  • org.apache.kylin:kylin-common-serverMaven

    From 4.0.0 · fixed in 5.0.3

  • org.apache.kylin:kylin-common-serviceMaven

    From 4.0.0 · fixed in 5.0.3

  • org.apache.kylin:kylin-core-commonMaven

    From 4.0.0 · fixed in 5.0.3

  • org.apache.kylin:kylin-core-metadataMaven

    From 4.0.0 · fixed in 5.0.3

  • org.apache.kylin:kylin-ops-serverMaven

    From 4.0.0 · fixed in 5.0.3

  • org.apache.kylin:kylin-serverMaven

    From 4.0.0 · fixed in 5.0.3

References 1

lists.apache.org