Skip to main content
← All vulnerabilities
CVE-2025-61594GHSA-J4PR-3WM6-XX2R

URI Credential Leakage Bypass over CVE-2025-27221

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.12.5, 0.13.3, 1.0.4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • ruby uri

    fixed in 0.12.5; From 0.13.0 · fixed in 0.13.3; From 1.0.0 · fixed in 1.0.4

  • uriRubyGems

    fixed in 0.12.5

  • uriRubyGems

    From 0.13.0 · fixed in 0.13.3

  • uriRubyGems

    From 1.0.0 · fixed in 1.0.4

References 4

GitHub · ruby/uri

hackerone.com

GitHub Advisory Database

ruby-lang.org