Skip to main content
← All vulnerabilities
CVE-2025-59328GHSA-5HMF-8WX5-4QQ3

Apache Fory: Denial of Service (DoS) due to Deserialization of Untrusted malicious large Data

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.12.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

A vulnerability in Apache Fory allows a remote attacker to cause a Denial of Service (DoS). The issue stems from the insecure deserialization of untrusted data. An attacker can supply a large, specially crafted data payload that, when processed, consumes an excessive amount of CPU resources during the deserialization process. This leads to CPU exhaustion, rendering the application or system using the Apache Fory library unresponsive and unavailable to legitimate users. Users of Apache Fory are strongly advised to upgrade to version 0.12.2 or later to mitigate this vulnerability. Developers of libraries and applications that depend on Apache Fory should update their dependency requirements to Apache Fory 0.12.2 or later and release new versions of their software.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • org.apache.fory:fory-core

    From 0.5.0 · through 0.12.1

  • org.apache.fory:fory-coreMaven

    fixed in 0.12.2

References 1

fory.apache.org