Skip to main content
← All vulnerabilities
CVE-2025-59302

Apache CloudStack: Potential remote code execution on Javascript engine defined rules

Published
Last modified
published
Not listed in CISA KEV
Low (apache)
Fix
Fixed in 4.20.2, 4.22.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

In Apache CloudStack improper control of generation of code ('Code Injection') vulnerability is found in the following APIs which are accessible only to admins. • quotaTariffCreate • quotaTariffUpdate • createSecondaryStorageSelector • updateSecondaryStorageSelector • updateHost • updateStorage This issue affects Apache CloudStack: from 4.18.0 before 4.20.2, from 4.21.0 before 4.22.0. Users are recommended to upgrade to versions 4.20.2 or 4.22.0, which contain the fix. The fix introduces a new global configuration flag, js.interpretation.enabled, allowing administrators to control the interpretation of JavaScript expressions in these APIs, thereby mitigating the code injection risk.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache CloudStack

    From 4.18.0 · fixed in 4.20.2; From 4.21.0 · fixed in 4.22.0

References 1

lists.apache.org